WordPress LifterLMS 4.21.0 Cross Site Scripting

0

[ad_1]

WordPress LifterLMS plugin version 4.21.0 suffers from a persistent cross site scripting vulnerability.

MD5 | c047b79bb03f1a1f0db714247c79a29b
# Exploit Title: WordPress Plugin LifterLMS 4.21.0 - Stored Cross-Site Scripting (XSS) 
# Date: 2021-05-10
# Exploit Author: Captain_hook
# Vendor Homepage: //lifterlms.com/
# Software Link: //github.com/gocodebox/lifterlms/releases/tag/4.21.0
# Version: LifterLMS # Tested on: ANY
# CVE : CVE-2021-24308

#Summary:

The 'State' field of the Edit profile page of the LMS by LifterLMS – Online Course, Membership & Learning Management System Plugin for WordPress plugin before 4.21.1 is not properly sanitised when output in the About section of the profile page, leading to a stored Cross-Site Scripting issue. This could allow low privilege users (such as students) to elevate their privilege via an XSS attack when an admin will view their profile.

#Proof_of_Concept:

1- As a Lowest Privilege user go to the edit account page of the LMS
(e.g //example.com/my-courses/edit-account/)

2- Put Your XSS payload in State parameter and save your edits, such
as ">

3- The XSS will be stored and triggered in the about section of the profile: (e.g //example.com/directory/[user_name]/) (Note): The XSS will also be triggered in the admin dashboard when viewing the user details, for example //example.com/wp-admin/admin.php?page=llms-reporting&tab=students&stab=information&student_id=2

Refernces:

//github.com/gocodebox/lifterlms/releases/tag/4.21.0



[ad_2]

Source link

Leave a comment